Mac snow leopard 安裝 tornado

tornado 官方網頁上寫的, Mac 10.5/10.6 要跑 tornado 需要先裝 setuptools, pycurl 跟 simplejson, 指令如下:

sudo easy_install setuptools pycurl==7.16.2.1 simplejson

( 不過其實我不太懂… 不是有 easy_install 就是有裝 setuptools 了嗎? )

不過我在 snow leopard 安裝 pycurl 失敗了, 所以 google 了一下, 將 ARCHFLAGS 改為 x86_64 就行啦

sudo env ARCHFLAGS="-arch x86_64" easy_install setuptools pycurl simplejson

接著抓 tornado 回來安裝, 就可以開始跑啦 :D

tzangms

Read more posts by this author.

Subscribe to Oceanic / 海海人生

Get the latest posts delivered right to your inbox.

or subscribe via RSS with Feedly!